Download & Install

Author Gravatar Image PHILLIP BURGESS
We’ll install the software next, because it’s easier to test and troubleshoot the electronics on your desk than behind the telly!

Three packages need to be downloaded:

Download Arduino IDE

First, download the Arduino IDE (integrated development environment) from the Arduino web site. Select the version of the software for your computer type: Windows, Mac or Linux. Read the Getting Started page for an explanation of how to install the software on your computer. It’s a little different for each of the three operating systems.

Download Processing IDE

Next, download the Processing IDE from the Processing web site. The first section of the Getting Started page explains how to install the software.
The Arduino and Processing IDEs look VERY similar! If you encounter problems with the Adalight code, you may have loaded it into the wrong IDE.

Download Adalight ZIP

Finally, visit the Adalight page on Github and download the ZIP file. The download button is near the upper left of the page:
After uncompressing the ZIP file, you’ll need to move some files into place.

If you’ve run the Arduino and/or Processing IDEs before, there will be corresponding “Arduino” and “Processing” folders inside your personal “Documents” folder (or “My Documents” in Windows). In that case, move the contents of the Arduino and Processing folders from the Adalight ZIP file into the corresponding document folders.

If the Arduino and Processing folders don’t yet exist on your system, you can just copy these from the Adalight ZIP file to your Documents folder.

The other files and folders in the ZIP file can be ignored. These are for advanced users and aren’t essential to its use.
Exit the Arduino and Processing IDEs if they’re running. The newly-installed folders aren’t visible until the next time these programs start.

Program the Arduino

The Arduino IDE must be installed before this step.

Connect the Arduino board to your computer with a USB A-to-B cable. When connected for the first time, Windows users will prompted to install a driver. This is explained in the Arduino Getting Started guide for Windows. No driver is required for Mac or Linux.

Launch the Arduino IDE. After a moment, you should see a simple blue and white window with some buttons.

From the File menu, select Sketchbook, which should “roll over” to show LEDstream. Select this.

From the Tools menu, select Board, then Arduino Uno (or whatever Arduino board type you’re using).

From the Tools menu again, select Serial Port, and then the port corresponding to your Arduino board.

Click the Upload button near the top-left of the window:
After the code is uploaded, if the LEDs are correctly wired up and the power supply is plugged in, the LEDs should all flash red, green, then blue for about a second each, then off. This is a startup diagnostic that tells you the LEDs and Arduino are working correctly, and are now awaiting data from the computer…

Because the Arduino stores the program in non-volatile memory, you should only need to do this upload process once, not every time you want to use Adalight.
If the LEDs do not flash, make sure all the wiring matches the previous page, and that the power supply is plugged in.
Last updated on 2015-05-04 at 04.27.56 PM Published on 2012-07-29 at 11.58.37 AM