The Arduino Philhower core provides support for RP2040 microcontroller boards. This page covers getting your Arduino IDE set up to include your board.

Arduino IDE Download

The first thing you will need to do is to download the latest release of the Arduino IDE. The Philhower core requires version 1.8 or higher.

Download and install it to your computer.

Once installed, open the Arduino IDE.

Adding the Philhower Board Manager URL

In the Arduino IDE, and navigate to the Preferences window. You can access it through File > Preferences on Windows or Linux, or Arduino > Preferences on OS X.

The Preferences window will open.

In the Additional Boards Manager URLs field, you'll want to add a new URL. The list of URLs is comma separated, and you will only have to add each URL once. The URLs point to index files that the Board Manager uses to build the list of available & installed boards.

Copy the following URL.

https://github.com/earlephilhower/arduino-pico/releases/download/global/package_rp2040_index.json

Add the URL to the the Additional Boards Manager URLs field (highlighted in red below).

Click OK to save and close Preferences.

Add Board Support Package

In the Arduino IDE, click on Tools > Board > Boards Manager. If you have previously selected a board, the Board menu item may have a board name after it.

In the Boards Manager, search for RP2040. Scroll down to the Raspberry Pi Pico/RP2040 by Earle F Philhower, III entry. Click Install to install it.

Installing a new board package can take a few minutes. Don't click Cancel!

Once installation is complete, click Close to close the Boards Manager.

Choose Your Board

In the Tools > Boards menu, you should now see Raspberry Pi RP2040 Boards (possibly followed by a version number).

Navigate to the Raspberry Pi RP2040 Boards menu. You will see three different versions of every board available: the board name, the board name followed by (Picoprobe), and the board name followed by (pico-debug). Unless you are specifically familiar with the other two, always choose the simple board name version.

Navigate to the Raspberry Pi RP2040 Boards menu and choose Adafruit MacroPad RP2040.

If there is no serial Port available in the dropdown, or an invalid one appears - don't worry about it! The RP2040 does not actually use a serial port to upload, so its OK if it does not appear if in manual bootload mode. You will see a serial port appear after uploading your first sketch

Now you're ready to begin using Arduino with your RP2040 board!

This guide was first published on Jun 30, 2021. It was last updated on 2022-01-27 17:56:49 -0500.

This page (Arduino IDE Setup) was last updated on May 28, 2022.

Text editor powered by tinymce.