Arduino 1.6.x IDE

The Arduino IDE version 1.6.x is the latest version of Arduino and recommended for most users.  Follow the steps on this page to learn how to install a version of the Arduino 1.6.x IDE with support for Adafruit's boards.

Super Easy Installation (Recommended)

With the Arduino IDE version 1.6.4 and greater you can now add 3rd party boards directly from the stock IDE!  The first thing you will need to do is to download the latest release of the Arduino IDE. You will need to be using version 1.6.4 or higher:

After you have downloaded and installed the latest version (remember it must be 1.6.4 or higher), you will need to start the IDE and navigate to the Preferences menu. You can access it from the File menu in Windows or Linux, or the Arduino menu on OS X.

A dialog will pop up just like the one shown below.

We will be adding a URL to the new Additional Boards Manager URLs option. The list of URLs is comma separated, and you will only have to add each URL once. New Adafruit boards and updates to existing boards will automatically be picked up by the Board Manager each time it is opened. The URLs point to index files that the Board Manager uses to build the list of available & installed boards.

To find the most up to date list of URLs you can add, you can visit the list of third party board URLs on the Arduino IDE wiki. We will only need to add one URL to the IDE in this example, but you can add multiple URLS by separating them with commas. Copy and paste the link below into the Additional Boards Manager URLs option in the Arduino IDE preferences.

If you don't see the Additional Boards Manager URLs box, make sure you downloaded the Arduino IDE from arduino.cc! Older versions and derivatives of the IDE may not have it

Add the Adafruit Board Support package!

Paste

https://adafruit.github.io/arduino-board-index/package_adafruit_index.json

Into the "Additional Board Managers URLS" box

Click OK to save the new preference settings. Next we will look at installing boards with the Board Manager.

Manage Board Support

Adding the link to the Adafruit board support package does not actually install anything, it only tells the Arduino IDE where to find the software.

Now that you have added the appropriate URLs to the Arduino IDE preferences, you can open the Boards Manager by navigating to the Tools->Board menu.

Once the Board Manager opens, click on the category drop down menu on the top left hand side of the window and select Contributed. You will then be able to select and install the boards supplied by the URLs added to the prefrences. In the example below, we are installing support for Adafruit AVR Boards, but the same applies to all boards installed with the Board Manager.

Next, quit and reopen the Arduino IDE to ensure that all of the boards are properly installed. You should now be able to see the new boards listed in the Tools->Board menu.

Finally follow the steps below for your platform to finish the installation - basically installing drivers and permissions management

Also check out the troubleshooting section for some advice on common errors.  Have fun using Adafruit's boards!

All-in-one Installation (not recommended!)

If you have trouble using the super easy installation method above another way to install support for Adafruit's boards is with the following preconfigured Arduino IDE downloads.  It isn't recommended because you wont have the latest IDE!

Just grab the right file for your platform and use it like the normal Arduino IDE.  Adafruit's boards like Trinket, Pro Trinket, Gemma, and Flora are configured to show up in the board list automatically

Once you've downloaded and installed the IDE follow the steps below for your platform to finish the installation:

Also check out the troubleshooting section for some advice on common errors.  Have fun using Adafruit's boards!

Manual Installation (super advanced!)

If you have your own version of the Arduino IDE or would like to install the Adafruit boards yourself then follow the steps below.  However it is highly recommended that most users stick to the initial methods

With the 1.6.x version of the Arduino IDE the process of adding support for new boards is much simpler than previous versions.  First start by downloading a version of the Arduino 1.6.x IDE and installing it as normal.  Note that these instructions are only tested to work against the Arduino 1.6.4 IDE, earlier or later versions may or may not work!

Once you've installed the stock Arduino IDE download and unzip the following file which contains Adafruit's board definitions:

Unzip the file and navigate inside the Adafruit_Arduino_Boards folder to find a hardware subfolder with a small hiearchy of files, and a drivers folder with Flora drivers specific to Windows.

Next find your installed Arduino IDE's hardware subfolder.  For Windows and Linux the hardware subfolder should be directly beneath the folder where Arduino's IDE was installed.

For Mac OSX the folder is hidden inside the application bundle.  Right click on the Arduino application and click 'Show Package Contents', then navigate to the Content -> Java -> Hardware folder to find the hardware subfolder.

Once you've found Arduino's hardware subfolder carefully merge in the contents of the hardware folder from Adafruit's board definitions, being sure to overwrite any file that conflicts (only avrdude.conf should conflict).  When you're done the Arduino hardware folder should have the following hiearchy:

  • hardware
    • adafruit
      • avr
        • The contents of the hardware/adafruit/avr folder from Adafruit's board definitions.  There will be a boards.txt, platform.txt and variants subfolder.
    • arduino
      • No changes to this hiearchy, it is exactly as provided by the Arduino IDE.
    • tools
      • avr
        • etc
          • avrdude.conf - This version of avrdude.conf should be from Adafruit's board definitions and completely overwrites the version provided by the Arduino IDE.
        • ... all other files as provided by the Arduino IDE.
      • ... all other files as provided by the Arduino IDE.

Finally on Windows only, copy the contents of the drivers folder from the board definitions download into the Arduino IDE's drivers folder (it's a sibling of the hardware folder you found earlier).

That's all you need to do to manually install Adafruit's boards with the 1.6.x version of Arduino!  Now follow the steps below for your platform to finish the installation:

Also check out the troubleshooting section for some advice on common errors.  Have fun using Adafruit's boards!

Last updated on 2016-11-22 at 03.07.17 PM Published on 2015-04-05 at 10.34.16 PM