Parts in Eagle are stored in library files with a .lbr extension. Creating these parts from scratch to populate a library can be a time consuming process. It's possible to extract parts from existing PCB files for re-use or importing into your own libraries.

For example, let's say you have a custom board you are working on and plan to use the LIS3DH accelerometer. There's one of those on the Circuit Playground Express. Here's how you can can extract the LIS3DH Eagle part from the Circuit Playground Express PCB files.

Extracting Parts

Be sure to run the following from the schematic window.

In the board view window, select

File->Export->Libraries

(this is just a shortcut to exp-lbrs.ulp)

This will bring up the Export dialog.

In the Path: window, provide a location for the libraries to be extracted to.

Now sit back and relax. Another window will open and stuff will happen while the export runs. This can take several minutes depending on how many parts are being exported.

Look in the window title bar for a report on the export progress.

When done, it will leave the newly created library open in the library editor.

Click the Table of Content icon (looks like open book) to see the listing of all the parts.

You can continue to view and edit the library, or just close this window. The library file should be created in the location you specified earlier. The file will have an .lbr extension.

Be sure to move the library to an Eagle Libraries directory location.

To access the library, it should be located in one of your Eagle Library directory locations. To check from the Control Panel:

Options->Directories

It also needs to be "enabled" for use in the Control Panel.

Importing Parts

You can use parts directly from the library file created via the export script. Or you can import specific parts into your own library files. In Eagle, there are several items associated with a part:

  • Device - Footprint + Symbol
  • Symbol - used on schematic
  • Footprint - used on board

To import a part, first make sure the library is located in an Eagle Library directory and is set to Use.

In the Control Panel, open the library file you want to import into:

File->Open->Library...

You can either import the entire part (device) or just the footprint/symbol.

Most likely, you want to Add Device.

In the dialog that pops up, click the Import... button.

Find the previously exported library.

  • Expand the library to show all the parts.
  • Select the device you want to import.
  • Click OK.

The part is now imported into the library. Note that the device, footprint, and symbol are all added.

This guide was first published on Sep 20, 2021. It was last updated on Sep 20, 2021.

This page (Extracting Parts) was last updated on Oct 15, 2021.

Text editor powered by tinymce.